System Outage
Incident Report for AccuPoint Enterprise
Resolved
We have identified and resolved the issue that impacted your ability to access the AccuPoint application. We apologize for any disruption and inconvenience. Please reach out to our dedicated support team with any questions.
Posted Apr 22, 2022 - 12:41 EDT
Investigating
AccuPoint is currently investigating a system-wide outage. During this time, you may not be able to access the application. We are working diligently to resolve. We will provide another update within the hour. Please reach out to our dedicated support team with any questions.
Posted Apr 22, 2022 - 12:36 EDT
This incident affected: Practice Management Application.